Back to overview

Chain AppHash

May 20 at 07:20am EDT
Affected services
Sei Global RPC CloudFlare
Sei Global REST CloudFlare

Resolved
May 20 at 07:20am EDT

At 10:23AM UTC, all Sei RPC nodes AppHashed and halted on block 148208223. These nodes were running a hotfix version of the binary provided to solve a different node-halting issue.

Nodes have been reset with an older binary and services are recovering. Some blockchain history may be removed, this will be resolved back to a minimum of 4M blocks/node today.

Update as of 16:30 UTC:

All nodes have been available as of approximately 12:30 UTC. Currently, selective nodes will be down for replacement with larger datasets to ensure more blockchain history is available. This will not cause downtime.

Sei team has reproduced the issue and is working on a fix. For now we're running an older binary.

Update as of 21/5/2025 at 14:30 UTC:
Sei team released a fixed binary that addresses the apphash as well as the previous debug_trace issue. Running this version on all nodes. Replaced state on state-synced nodes with a larger snapshot with more history.

Closing this update.